360 TE Stick major issues on PC, works fine on console

Hi guys, I have a serious problem with my TE stick and I’m hoping some of the tech gurus here could help me out.

Basically, my 360 Madcatz TE stick works great when I’m using it on my 360. It also worked perfectly fine on PC, where I used it for GGPO and SF4 PC.

A couple of days ago, however, for some reason the stick started acting erratically. 1/4 times a direction I input will not come out. Some times the stick just acts is if stuck in one direction and keeps going (I’ve had Chun Li just constantly walk backwards while playing 3rd Strike on GGPO).

I haven’t updated the drivers or installed any new software that would interact with the stick, so I’m truly at a loss here. Again, the stick works fantastic when used with my XBox. I’m running Windows 7 x64 and the stick had worked fine for a couple of weeks at least.

Has anyone experienced something like this? Thanks in advance for any response.

Sounds like the LS issue, is your stick set to dpad?

It happens with both d-pad and LS.

Perhaps your stick is flipping out and the 360 is just more lenient than your PC, so nothing happens. Your PC might be more sensitive to the problem and that’s why it shows up there. Don’t know what to do about it though. =(

you should at least go ahead and uninstall the drivers and start fresh.
i would also try and hook it up to a different pc to see if it happens again.

No offense but I’m pretty sure there’s no such thing. You either input something or you don’t, my problem is that the PC is not recognizing inputs 1/4 or 1/5 times. Especially if the inputs are coming out fast (for example if I flick the stick left/right really fast my character will not move left/right at least 1/4 times)

I don’t have a second PC to try it on but I’ll look for something.

Are you sure it’s not that same old “washer problem” that’s been plaguing these Mad Catz sticks from the beginning?

But if that were the case, wouldn’t the problem show up on my 360 as well? The stick works fine there.

It’s a TE, washer problem I believe is only on the MadCatz JLF clones in the SE.