360 not detecting TE Fightstick

I only saw a main thread for SE FightStick issues…

Just tried powering on my 360 with the XBox logo button on my Fightstick, but the XBox would not power on. After hitting the power on the console itself, none of the controller lights around the power button are lighting up. I’ve tried the other USB ports without any luck. The USB ports do work, since my Rock Band controllers light up fine when plugged in. I’ve also checked the breakaway cable, along with trying others, but that doesn’t work either. One thing I’ve noticed is that when the console is on, and I plug in the joystick, the red turbo indicators all light up faintly for a fraction of a second, then go back off. I have no idea how this problem started since the stick was working great just an hour ago and its been untouched since I stopped playing. Gonna call MadCatz support in the morning. Anyone have any ideas? Also, is the turnaround time really 4-6 weeks for warranty support?

Try to keep plugging it in and out until it turns on. For some reason I have to do this with my Usb wireless adaptor.

Didn’t work. I sent an email to support, since I’ve already been on hold for half an hour. I guess they have a large queue of calls (even though I called right at 8, when they opened). I hope this is isolated and not another QC issue.

Do other USB accessories work? Will the stick work if you plug it in your PC?

Other USB accessories work. Does the stick need drivers when plugged into a PC?

I had a similar issue with a friend’s custom stick that used a Madcatz PCB, it ended up being the breakaway cable. Had the exact symptoms you mentioned and was easy to swap out.

Are breakaway cables compatible across all peripherals? I’ve tried the breakaway cables from my Rock Band controllers without any luck.

Make sure the connection from the stick to the breakaway cable is connected fully. I’ve had this issue a few times were the connection wasn’t fully in. Then plug the stick into the xbox.

Javi! Long time, dude.

Anyways, I’ve connected the breakaway as much as it can go, but it just won’t detect. Doesn’t seem like I can do much but wait for MadCatz to email back. =(

I swear, my experience with MadCatz support has been terrible so far. Nobody answers for over an hour, I call back and leave a message yesterday (have not received a call back), email them yesterday (no reply). I’m almost tempted to try to fix it myself. I’m already wishing I picked up an HRAP.

honestly i say fuck the warranty open it up take some pics and ask for help

the WORST POSSIBLE thing that can happen is you just having to put a new pcb in that bad boy.

oOmzaOo, test the stick on a PC, make sure it works there. If it doesn’t come up on the PC, then I’d triple check the detach. If it doesn’t work on PC and its not the detach, MadCatz should fix it under warranty as a hardware failure, either the main PCB or with the cord.

Now, the bitch of it; if it works on PC, but doesn’t on the Xbox, and you can swap in other wired Xbox stuff into that same USB port and have them work (proving the USB port is still good), then I REALLY want to hear about your experience when you finally get ahold of MadCatz. There’s an Xbox security chip that is checked whenever plugged in by a request from teh Xbox. We’ve seen a number of them failing, resulting in a stick that won’t authenticate on an Xbox360, but works fine on a PC. If its the security chip, I really want to hear if MadCatz will recognize and swap you out.

Thanks for the suggestions. PC doesn’t detect it either. I’ll let everyone know what MadCatz says.

I just received my TE stick (360) today and am having a somewhat similar issue.

My stick works fine, except for that it will randomly disconnect/reconnect without any notice. By this I mean that it will flash the reconnect controller message, which will immediately disappear, as if someone unplugged and plugged it right back in.

I’ve checked the break-away part of the cord and the USB plug-in and it all seems to be fine.

I’m going to check madcatz site/call customer support immediately after posting this, but I figured I would put this out there to see if anyone may have a similar problem or a possible solution.

Exact same thing happened to me, OP down to the turbo indicators flickering. I spoke with MadCatz customer service this morning and they’re sending me postage and asked me to ship it back to them for repairs.

I wonder if it’s widespread.

Not working on the PC sounds like PCB failure or the solder point where the USB cable attaches to the PCB is messed up somehow.

Just got my stick back from MadCatz yesterday. Took them two weeks (they said it was a bad PCB). I plugged it in and it worked. Today, I tried to power up the XBox using the X-logo button on the stick. It didn’t work, so that immediately worried me. I powered on the XBox from console and NOTHING lit up on the stick. I don’t get it. Is the console not liking how I power on/off the system via the controller? Looks like it’s another call to tech support. Sucks even more that I have to wait until Monday and no SF4 for the weekend. Lame.

Wow this makes me real sad. Where is the Quality control?

I got my TE on Thursday and played it for like 2 hours, no problems what so ever and left the x360 off and the TE plugged in, tonight I go to power up the x360 and nothing, I plug and replug the stick nothing its like dead! Will try the PC later after this post. Man this so irks me.

Wow again, using my PC to connect its doesn’t work?!?! Got a dead POS PCB? God damnit.

Gonna return this to amazon this week sigh.

I think somehow the 360 is shorting the TE out when it’s off…

But that dosn’t make sence at all…

My TE is always plugged into my 360 and hasn’t had such an issue, yet at least.