The official Cthulhu and ChImp thread - Try our new Dreamcast flavor!

I was wondering if anyone had success/problems using a cthulhu stick with fighterz on pc?

Well its Dinput only and the Joystick defaults to using both POV Hat as well as X Y Axis on Windows.
You can over ride one input or another by holding Select or Start whole plugging in the stick (I always forget which does which).

Example for Mame, I would force XY Axis only and set the controls in the setting.
Next time I play mame, the setting are in place and the program ignores the POV Hat.

Games that require Xinput, well you have all the usual work arounds, x360ce, Joy2Key, Steam’s own built in Plug in, Ect
As well as Dual-modding with a compatible Xinput Board (Like a Xbox 360 or Xbox One PCB).

Anyone have one pre made for dreamcast for sale?

@l3et9jdh Just pick one up and get to soldering. Soldering is easy, just watch a few videos on youtube or go to Fry’s Electronics and pick up on of their soldering practice kits. I don’t recommend the iron in the starter kit because it doesn’t get hot enough, but they give you PCBs and wires to solder together for practice. Also, Home Depot is a good place to get a decent soldering iron. Good luck!

Anyone know why Button 13 is constantly showing up is being pressed down in the Device Manager on Windows? I have to use JoyToKey to play on FightCade etc since I can’t set my inputs properly (“waiting for Joy 0 X to release”)?

Make sure you dont have anything bridged or connected on the board that shouldn’t be

Hi everyone!

After having successfully modded my Xbox 360 Fightstick TE Round 1 with a TE-Kitty a while ago, I finally recently got my hand on a common ground 360 controller PCB to dual mod my PS3 Fightstick SE with the MC-Cthulhu I ordered at the same time as the TE-Kitty.
Both have an RJ-45 passthrough.

It wasn’t easy finding all the necessary info with all the broken links due to the forum changes and missing pictures, but I got everything I needed and it is working correctly (except I couldn’t keep the lock button of the turbo panel working as it should… I tried different ways of soldering it, but I could only have it working reversed :stuck_out_tongue: That’s good enough).

An issue I’m still having trouble with is making an NES cable.
I had a hard time when I tried it for the TE-Kitty, and same thing now with the MC-Cthulhu.

I used the same pinout I found in my notes from back then which is still the same as found in the RJ-45 Multi Console Cthulhu Arcade Stick Tutorial Ver.2.
And the pictures from rtdzign’s photobucket:


I have the same behavior with my new cable than the ones I made previously for the TE-Kitty.
The Start button seems to work, Select seems to do the same as Start, right seems to trigger right, up and A at the same time, and down seems to trigger down, left and B. A/Cross seems to trigger the A button instead of being on B/Circle.

On the TE-Kitty, the behavior is different but still the same with both new and old cables.
No directions work, neither are Start or back, and A(XB) seems to trigger Start and A(NES) instead of B.
X doesn’t do anything on its own, but if pressed and held at the same time as A (and releasing A), it seems to trigger Start constantly, like turbo but on start instead of B.

I tried on my PAL NES, I think on one of my friends’ too and on his Analogue Nt Mini, either plugged in when powering on or plugging in afterwards and same thing.

Is the pinout provided by rtdzign correct ?

Purpose -Pin # - Cthulhu Column
GND -1 - G
CLK -2 - A
LATCH -3 - F
DATA -4 - C
VCC -7 ? V

Thanks in advance for your help!

Yep that is the correct Pinout

Hi, thank you for your response.
Are the wires matchting correctly as well ? (1G, 2A, 3F, 4C, 7V)

Do you have any idea what could cause this behavior ?

Today I was ready to mod my PAL SNES since my Round 1 TE with TE-Kitty doesn’t work correctly on it.
My friend’s stick (same) doesn’t work either on my console, but both work correctly on his US SNES and Super Famicom, so I thought it was the region locking of the controllers that was the issue.

So just to be sure, I’m testing again, and it’s still happening. But my newly modded SE with MC Cthulhu works correctly with the same cable :astonished:

Could anyone confirm that the wiring of the cables is the same for TE-Kitty and MC Cthulhu ?

Are both boards considered from different “regions” ?

(and my previous question about the NES cable still stands :wink: )

Thank you!

Pal SNES consoles normally do not work with NTSC controllers.
The Kitty and MC Cthulhu is based off the NTSC versions of the controller.

But there is a fix, and you need to open up your SNES to do this
There 4 diodes you can ether remove and replace with wire, or just bypass the diodes with some wire on the controller interface daughter-board.

Here are the 4 Diodes you need to bridge,

Yes, that’s what I wanted to do, but when I tried the MC Cthulhu on it, it worked, contrary to my TE-Kitty.
So I wondered if that was the issue…

I guess I’ll do it anyway just to be sure.

Also, do you have any idea why I can’t get them to work correctly on any NES ?
Thank you for confirming the pinout. Are the wires matching correctly too ?
(1G, 2A, 3F, 4C, 7V)
That would be contacts number 1,2,4,7,8 on the RJ-45 connector.
I think the wires color is standard for the NES (official, at least) controllers.
On both my cables, I have 1: brown, 2: red, 4: yellow, 7: orange and 8: white.

Never go with other people’s wire colors, as they can be wrong.
Even Nintendo themselves are known to change up with colors they used.

Go with a multimeter and test pins, and right what colors you have that matches those pins.

Yes, that’s what I did, I tested every cable.
It ended up being the same colors.
(I even think the colors are not provided in the tutorial thread, for the exact reason you mentioned)

Sounds like capacitors are stacking and fucking up the voltage the pads need to get signals on one board but not the other?

Can you perform an update without it being in a stick? Like touch a wire from select and start and ground while plugging it in to get it to bootlogger mode? It seems to be unresponsive when trying it with a undamned usb decoder. The udusb is getting power but the board isn’t doing anything. I’ve checked my connections via continuity all over and it seems I got a dead board.

This topic was automatically closed after reaching the maximum limit of 10000 replies.