The official Cthulhu and ChImp thread - Try our new Dreamcast flavor!

Yeah. I had thought about that too just yesterday but didn’t find any agetec in the trading outlet or eBay.

I just got one of these (MC Cthulhu) and put together a bunch of rj45 cables for all of my consoles (NES, SFC, PCE Duo R, Dreamcast, Playstation, and Xbox). Too bad it doesn’t work with the Genesis but I have a stick on there that works fine. I mostly like playing arcade ports, I’m not a huge fighting game pro. I put the chtulhu in a Fightstick Pro Street Fighter X Tekken stick I had lying around that I originally bought for MAME before I got all of my retro consoles. This hs brought so much life back to it. When it works as expected it’s fantastic. Unfortunately I’ve run into a few issues and I’ve googled around but this is a huge thread and some things while having been mentioned, sometimes don’t have answers. Since it’s been a few years since some of these questions were asked with no definitive solution, I thought I’d ask them again since maybe there are new answers that just haven’t made it to the forums. Also, I have already updated to the latest firmware and tried both the 1ms and 10ms versions but neither of them changed my issues below.

NES: Sometimes the stick just doesn’t work. If I power off and back on, sometimes it will work. Sometimes it takes 5 power cycles to get it working. (My NES has an everdrive if that matters, I know they consume more power than a typical cartridge and if this is a power issue that might be a direction to look) . When it does finally work, it’s flawless.

Super Famicom: No issues (admittedly I haven’t used this console much since I modded the stick, but when I used it there were no issues)

PC Engine Duo R: This is the one with big problems. I have a Turbo Everdrive switched to the “PCE” position (since the pins are rearranged from US Hu Cards) and with a regular 2 button PCE pad it works flawlessly. When using the stick all of the controls are all mixed up. Up and Down on the stick do the expected action, but Right does indeed register as right, but it also triggers button II. Left is even worse because it triggers Run as well, so nothing is playable. This has been mentioned in the thread before, but it was 3 years ago, so I don’t know if there is any solution. When playing CD games the stick works perfectly, it’s only Hu Card games and it’s every one I’ve tried. I have not tried with a multi-tap (don’t own one) but the other person with this problem said that a multi-tap didn’t fix it for him. He was using an American Turbografx 16 with an adapter and japanese Hu cards. His American ones worked fine. Once he got a Turbo Everdrive (switched to the TG16 position) all of his games worked. It’s definitely an issue with Japanese Hu cards, and since my everdrive is switched to PCE in a japanese system (it doesn’t work any other way) essentially all of my games are Japanese Hu cards, even the american ones.

Dreamcast: Amazing, works every time, and it’s so nice to play all of the arcade ports with a great stick

Playstation: This is an odd one. It works every time, but games can’t read my memory card when the stick is plugged in. If i have a regular controller plugged in, the memory card is fine. If I have the stick plugged in, games say there is an error with the card. KoF 95 and The Raiden Project are the two I’ve tested but both complain about the memory card and fail to save or load. With a regular controller in they are fine. I tried another memory card and got the same thing too.

XBox: works great.

Anyway, this thing is awesome, I had a lot of fun putting it together, and even more fun playing tons of awesome old games with proper controls. I just wish I could get those few problems worked out. Does anyone know of any solutions?

Which MC Cthulhu should I get? The Jansen Custom ones (clearly marked as defective) or the Paradise arcade shop ones? Or are they the same thing?

The one from paradise arcade. They’re different.

With NES, try unplugging and replugging the controller cord after you power on a game. That almost always gets it working for me.

For SNES, some games work flawlessly and others don’t work at all in my experience. Donkey Kong Country is one of the games that never works for me with the MC Cthulhu, has anyone else had it work on that game? I’ve been waiting for years for someone else to let me know if their MC Cthulhu works on that game so I can figure out if mine is defective.

I dont have a DKC cart but i can give it a try with my SD2SNES with DKC loaded…

I have an old MC Cthulhu. (I took it out for ps360+ but put it back in since the advertised SNES support for ps360+ doesnt work and their support is dead now)
Anyway, the retro consoles are fine. And the USB worked for years until last week. Its stuck in bootloader mode. (I have the original mc cthulhu, not the jasens customs one). I checked to make sure home wasnt shorted with ground. What else could be causing this? I would prefer not to have to back put in the ps360+ again just for PC support… (And I’d need to buy switch too, either that or have to cables hanging out)

I recently ran into a similar issue. And, up until today, I didn’t think about my options. But after reading your post I got an idea. I have a PC Engine Duo R that has a region mod on it. I believe my Duo was set to Japanese (it’s not labeled which way is which) and my Everdrive was set to PC Engine. I ran into similar issues to what you described and I even had issues with US games like Bonk’s Revenge. It was really hard to pin down and due to other information I found I figured I was just SoL for a lot of games on the TG16/PCE. I swapped my region over to the opposite of whatever my PCE was set to and then flipped my Everdrive over to the TG16 setting. I can no play every single game that I tried to run (about 30) total. With most of those being Japanese titles. The only game that had messed up inputs still was Final Soldier (japanese). I have the normal version and the 2 minute time attack version. Oddly, the 2 minute time attack version has slightly different input issues. But every other game, including a ton of SHMUPS (most of my interested in the PCE besides RPGs), worked flawlessly.

So if your console happens to have a region mod, try what I tried. You might also see if you can get an adapter for US games to play on the PCE and put your ED into TG16 mode. That might accomplish the same thing as my region mod.

Also, since you have an Everdrive and an TG16/PCE and you try to use an MC Cthulhu based stick, you will have to unplug the stick and plug it back in once the game boots up. It’s as if the MC Cthuhlu thinks it’s a different system in the ED menu than it actually is. And what is doubly odd is some games will partially work. At least that was the case for me and my Duo-R and for @NoAffinity who made/tested the PC Engine cable I am currently using. If that is wrong @NoAffinity please correct me. And you probably already know this but just in case you don’t or people who read this in the future don’t…you all do now :slight_smile:

Also, do not forget that the Home/Guide button switches between 2 button, Neo Geo mode and 6 button mode. If one mode does not work swap to another. Oh, I also tested with a 5 player multi-tap when I still had my region/ED set to PCE mode and that didn’t fix anything.

Now it’s time to get back to Dentana!! Twinbee. That game is crazy fun and I loved renting the NES version when I was a kid for some reason.

@FrakkinToaster I can confirm that it’s not your unit. Mine, which seems to work on every other Super NES game I’ve tried, does not work with DKC 1, 2 or 3. I even tried turning off of the in-game hook/button menu stuff and did the unplug/plug in trick I have to do with my PC Engine. Nothing got it to work. Edit- I remembered I had an MSU-1 music hack version of DKC2 on my SD2SNES and that also does not work.

I believe all three games had some form of anti-piracy and I wonder if that has something to do with the MC Cthulhu not working. I did find a couple of posts that mentioned 3rd party controllers not working with DKC so that is possible. I tried other Rare-made SNES titles like Killer Instinct and Ken Griffey Jr.'s Winning Run and neither of them had an issue. And both were put out after the first DKC game.

It would be nice if the firmware code was passed on to an active dev who wouldn’t mind ironing out a few of the bugs with the board if given proper replication steps and maybe even access to hardware (I’d mail them consoles if it came down to it).

Would it be ok to wire up the pins used for a dual mod (marked A-H/1-9 in the manual) to a DB15 connector in order to connect the joystick to a Neo Geo?

I would also like to add that Ninja Gaiden Trilogy seems to have the same issue as DKC1, 2 and 3 in regards to the Cthulhu not working. If I find more games with this issue I’ll edit this post so there is some kind of record.

I mentioned before that Super Double Dragon doesn’t work with my TE Kitty. Dunno if it’s the same with the MC Cthulhu.

For which system?


Both Super Double Dragon and its Japanese counterpart (Return of Double Dragon) really don’t like the TE Kitty. I had to reflash the TE Kitty firmware at that point.

I’m not holding my breath for a fix. The shortened URL for Godlike Controls ( expired a couple weeks ago, though still works.

Are you using a US, Japanese or European SNES?

American SNES Mini (SNS-101), modded for RGB and s-video if that matters.

I’ve also heard of some NES games not working with the MC Cthulhu, but I’ve had good luck with the games I want to play. One quirk is I can’t change NESRGB color palettes with Start+Select+Right (NESRGB-IGR I believe) with my TE Kitty like I can with an official NES controller or a Capcom Power Fighter Stick.

Bout to install a couple of MC cthulthu in this cabinet. Just got done building it

Well the NESRGB-IGR PCB I believe was made well after toodles finalized is code for the MC Cthulhu and the two where never intended to work with each other.
The MC Cthulhu is listening on to the NES/SNES Clock, Latch and Data lines to know to switch over to NES/SNES functionality.

Obviously with the Reset of the console this also resets the MC Cthulhu and the MC Cthulhu have to grab data of latch and clock to find out what it’s trying to do again.

As for straight SNES games, the problem you experiencing is not well documented as the MC Cthulhu was only tested against most of the more notable fighters for the console.
Many SNES games are expecting Nintendo branded SNES controllers and the MC Cthulhu needs to do a “hand-shake” or listen to Clock and latch and data lines to know what system’s controller to emulate.

Actually handshake is the wrong term for whats going on in the computer logic, but for simplification I going with the term for now.
As the NES and SNES don’t actually send a handshake signal like you see with USB protocols.

Actual SNES and NES controller don’t use a real encoder like controllers for later consoles. Instead both the NES and SNES uses a parallel to series shift register (4021), taking the manual parallel inputs of the buttons and changing them into 8 bit binary information for the console to read.

The SNES and NES consoles already assumes the controller is the correct controller with a 4021, some games don’t send any data to the controller as they assume the 4021 is there and not something like the Cthulhu.
Some games does not allow for the console to initiate the “handshake” until the controller sends some data first. Some games look for a controller and sends a signal for the MC Cthulhu to listen to and know to switch to NES/SNES mode. The problem lies in the fact the Cthulhu is dependent on auto detection and some games and their own controller drivers aren’t built right, so the Cthulhu has nothing to listen to and adjust accordingly.

I think (but I am not too sure) you can force the Kitty into SNES mode, but I don’t know the button combination that allows for it. That work with some of the problematic games.
But it will not help with the NESRGB-IGR as the NESRGB-IGR forces a reset.

As for the Region question.
I know the European SNES has issues with any gamepad PCB not made for the European SNES, but there a simple mod that you just remove (and Jumper) or bypass some diodes on the Controller Inputs.
hence I asked what region you console is for.

question… my MC Cthulhu is not being detected when plugged into my PC… any idea what’s happening? i have it wired up to a rj45 to a dreamcast and it’s working perfectly fine on my Dreamcast. Im also able to put the board into bootloader mode on the PC… but other than that… the PC just doesnt recognize it. please help if you know something. thanks.

Check the pinout on your USB cable

i had the board plugged into the PC and Dreamcast at the same time… that was the problem. even though the Dreamcast was off. i didnt know that…i thought it was only an issue if both systems were on.

does that sound right? it seems be working fine out since i’ve disconnected the board from the dreamcast.