ps360+ problems

Hi guys,

I want to start off saying I’m a complete a-technical guy and I don’t understand much about the deeper workings of a pcb.

This problem has been bothering me (and my mod guy) for quite a while.

It started when I got my ps360+ placed about 2 months ago.
At first it worked completely fine and I enjoyed it for about a week.
Then suddenly, when plugged in, my stick stopped working and I had to reconnect it for it to work again (on ps3, xbox and pc).
This occurred more and more as time went on and I went back to my modder and he told me to get a new cable.
I got a new cable, same story, it worked for about a week and then it started disconnecting again.
My modder told me to come over and he placed the pcb in a more convenient place and installed some contraption that holds the cable in place while eliminating any disturbances.
He also got me a new cable (which was shorter which could have been the cause).
We tested it for about 3/4 hours and it was fine and I hoped it got better.
Then one week after at a tournament finals the same thing happened again, I reconnected and it happened the match after aswell.

See 7:08 and 10:19

Then last friday I went to the guy again and he hooked me up with a brand new ps360+.
Now today it started the same shit again and I feel like I’m out of options.

What do you guys think?


I forgot to mention before I got the new PS360+ my old one started being unresponsive and often unable to recognize double inputs (throw, focus attack etc)

Same issue…new pcbs…same modder…

Honestly, it could be that your guy is installing it incorrectly. I installed 4 PS360+s…no issues from any of the people I did it for.

There is a sudden influx of PS360+ problems. Is it the actual PCB or is it the faulty installation of new users?

I am biased to incline its the latter because of my success with the PCB, but I really dont know.

Well I got mine modded by some dude with an eye patch on a major couple months ago…

That “dude with an eye patch” is @DaRabidDuckie, probably one of the best modders out there.

In response to the OP I agree with DJYin, check the installation or at least post pics of the inside so we can help you a little better.
That PCB is very easy to install and yet there are so many people messing it up.

Is the USB cable permanently attached, or is it removable?

Have you updated the PS360+ to the latest firmware? A lot of issues like these seem to have been solved by the recent updates made to the board.

I always forget those things can be updated. Good call.

Here are a set of instructions and a link to the latest version of the firmware:

I just installed the new firmware a few minutes ago. The only hard part was getting my computer (running on Windows 7) to recognize the ATmega32U4 firmware.

It is removable.

I will try and snap some pics of the inside and also update the firmware later today.

Thank you all for trying to help me out

Why do we have 3 active PS360+ Thread with very similar issues?

I updated the firmware and went to gamecontroller settings in my configuration screen.
I started mashing triples and doubles and after about a minute the inputs stopped coming through.
It still says PS360+ v1.2 is connected but the inputs stop coming through.

Edit: It’s weird though that it still say v1.2 while I followed all the instruction and got the OK in FLIP.

It’s not that it’s not being recognized, it’s the inputs stop completely after a while.

You should test to see if it has physic contact problems. I had the similar issues with my stick and the problem was the USB port on the PCB. I was using different PCB though, not PS360. Connect everything, start the game and shake the stick as much as possible. Also, shake the USB cable inside and outside of stick to test if there are any physical connection problems. Also, you can try to shake a PCB a little, but be careful not to touch any of it’s components while it’s plugged in since the static electricity can damage your PCB. If you see “auto pause” and “reconnect controller” message, this might be the problem. Does this things happen on Xbox only, or they are happening on PS3 and PC?

It doesn’t disconnect it stops sending inputs, you don’t get a reconnect controller but it just doesn’t send anything. I tried shaking my stick and wiggle the cable but that doesn’t trigger the problem. If I put in 2 or 3 inputs (like an ultra throw or focus attack) it stops. It happens on PC and Xbox, haven’t tested long enough on a ps3 since I don’t own one.

You might have a short on the select line, and what’s happening is you are entering into the configuration mode when mashing shit out, which it then stops sending inputs. Pictures of your install would help but the first thing to do is start removing connections, in this case I’d remove select and test again.

Is that common? I use select for plinking but I could live without it if that solves the problem.

If you’re BLinking? Absolutely. Select+3P I believe enters configuration mode but I’ve come across that before when a buddy was doing it. I believe there’s a vanilla firmware that removes configuration modes if you need that for SF4 though. Or just don’t BLink ultras.

This is the inside of my Madcatz Versus

It still says 1.2 because you have to clear the registry name and update it manually. There are instructions in the ‘updating firmware’ documentation with the ps360+.

Either way, it seems that your issue most likely stems from either a) the connectors or cables involved with the removable USB setup, or b) the fact that you use select for blinking.

The first row on the page regarding firmwares for the PS360+ states “Updated Firmware with some fixes (…and ability to use Select + buttons)”.
So the firmware must be the reason for the issue.
The fact that the PS360+ still has the problem and because the firmware still reads 1.2 (which came out in before the problem was addressed) suggests that the update didn’t work and the firmware has not been updated.
The old firmware still exists, the problem still exists.

I’ve had the same problem where the firmware did not get updated on my computer, whatever i did, whichever version i tried. Eventually the PS360+ was connected by the customer to his macbook to update the firmware and it worked.