On my SE stick, if the RB button is being detected as being held down continuously

does that mean my main PCB is broken?

I have been playing on that stick for maybe 70 hours (after doing the washer fix), and it was fine for that time. Then all of a sudden RB stopped working. After much testing and deduction, I have determined that the controller somehow detects that I am constantly holding down the RB button, no matter what.

I tried unplugging all of the QDs, to no avail. No matter what I do, it thinks that I am holding down the RB button. Does this mean that my main PCB is done for? I can live with it I guess, as I rewired LB to the RB slot and changed the controls (and thus the game is perfectly playable), but it gets kind of annoying in menus and such. Also, I was planning on upgrading my parts, but I think it could be pointless if my main PCB is headed down the drain anyways.

Is there any fix to my problem? Has anyone else experienced this problem? Does anyone know the cause of this problem? I know that I have another topic about this situation, but my question went unanswered (I think because I made some conclusions about the problem like 12 posts into it).

PLEASE, PLEASE, PLEASE, I would appreciate it if anyone could give me feedback, even if it is just to tell me that Madcatz royally boned me. Thanks in advance.

Do you have a multimeter?

Its hard to tell whats going wrong without one.

Actually I have another really simple question.

If you take the Quick disconnect off of the RB button, does it still activate.

I believe he said it does, but I’m confused.

The Turbo is on, maybe?

Exactly why I asked, it’s hard to understand.

Because he mentioned hooking it up to the LB and it worked fine?

Jeez, sounds like the PCB is doing something. Toodles might be able to help you out. Hopefully he takes a look at this thread, or maybe send him a PM. Does the PCB look weird or out of the ordinary?

Have ya disconnected, and reconnected the QD’s on both ends?

I think he means he re-mapped the bumper, not rewired. Hard to tell though.

Let me rephrase that.

Hook your LB’s quick disconnects to your RB, if its firing rapidly, its the button.

If it’s not the button, then read below.

Hook your RB’s quick disconnects to your LB, if its firing rapidly its a short.

If it turns out to be a short read below.

If you have a multimeter.

Set it to OHMS rx10

Hold the the Black pin to a ground and the Red pin to the signal of RB, that’s the first step I would take.

Your multimeter may chill in the middle, if it does that’s good and there’s no short, but if its going off the charts, there’s is a short somewhere.

Thanks for the replies guys. Sorry I made it confusing.

What I mean to say is that, even when I take off all of the QDs for RB, RB doesn’t work. It is NOT the button, it IS something with the PCB.

What I did before is just rewire the LB wires to the button in the location of the RB. Kind of confusing sounding I guess.

Okay, so I guess the conclusion is that somehow the RB signal is being grounded? The problem is that I don’t have a multimeter, or really any kind of electronic equipment type stuff. Just a screwdiver, pliers, hammer, etc.

Would it help if I took some pictures of the PCB? In order to do that, I guess I would have to unscrew basically all of the screws in the innards of the stick to actually view the underside of the PCB.

Well, even if the scenario is that the signal is being grounded, how can something like this be fixed? Thanks again in advance.

^^When I said grounded I meant short, lol.

To make it even more clear, even when I remove ALL of the QDs from all of the buttons (like remove all 4 connectors on each QD) and set them aside from the stick, the RB button still acts as if it is being held down.


I took some pics of the inside of the stick. I know I switched the physical buttons, but that was just for testing purposes - the buttons are absolutely fine. I also switched some of the wires - again, for testing purposes - and the wires are also fine. As you can see, I remapped the LB wires to the RB button slot, so as to make the game playable.

I tried to unscrew and lift out the PCB, but that red gooky stuff made it very, very difficult. I don’t want to do it unless I absolutely have to (for fear of messing up and ruining the PCB altogether). If someone could help me if I did lift out the PCB, I would do it.


bump…in the hopes that someone who can help me will read this

For debugging purposes (not saying this will fix things, but at least it’ll give you an idea of what’s going on):
You might try to do is try and see if you can determine which PCB is flaking on you. You’ve got the PCB where all the buttons are going into (bottom left in your first picture) and the PCB where the USB cable comes in (bottom right). Try unplugging the ribbon cables from both the bottom left PCB and see if the problem still exists. If it’s still giving you the continuous input on RB, there’s a short on the PCB on the right side. If not, then there’s a problem either with some of the wiring or the PCB on the left side.

Thanks Jangie. I was thinking of doing this, but if I do detect a problem, is there really any way of fixing it? I mean I will probably just do it anyway (the only reason I haven’t until now is that there is so much goopy stuff all over the connectors) to see which part is problematic, but I would have more incentive to do it if someone knew how to fix the issue, lol.

Did you try claiming warranty and seeing if Madcatz can fix it?

I’m honestly not well-versed enough with the SE stick to make any comments on what would be the next step. If it is the right PCB, it’s probably time to send it in. If it’s the left one, I’m guessing based on the pictures that it’s basically just something to make the wiring a bit tidier; taking it out of the stick may help you see an obvious short. You may also be able to bypass the left PCB entirely by figuring out which pin on the ribbon cable corresponds to RB, and soldering that directly from the button to the right PCB. This would also entail clipping the wire on the ribbon cable corresponding to RB.

That said… you probably want to just send it in.

Will they let me send it in even after I did the washer fix?

IIRC as soon as you open the case you void the warranty.

I could be wrong though.

By the way, no one can help you until you have some way to test for shorts, aka a multimeter.

You could look for things that may be physically wrong with the wiring, but that’s about it.